25 sept. 2014

Solución para actualizar bash 4.2-2ubuntu2.2 en Guadalinex v8 y Ubuntu Precise

Estaba yo flasheando un Kernel en mi One plus One, al estilo hacker dv



y mientras optimizaba el arranque no dejaba de darle vueltas a este suceso.
Está mañana, vía Twitter y desde la oficina, JJ nos informaba de está grave vulnerabilidad. EL caso es que me puse yo con un servidor que tenemos con la distribución Guadalinex v8, basada en Ubuntu Precise 12.04 y una de tantas distribuciones expuestas a esta vulnerabilidad crítica en bash (Intérprete de comandos en Linux).
Cuando me puse a intentar upgradear (actualizar) para ver si con la actualización se solucionaba. Después de pelearme un rato con los repositorios Camaleon en el source.list que incluye Guadalinex v8 y algunos de Precise, no conseguía actualizar. Algo desesperado y viendo de que no conseguía solucionar el desaguisao de los repositorios, me hice de un nuevo comando en GIT
git help me JJ
gracias a este nuevo comando apareció a una velocidad de 200MB, por lo menos, y solucioné (más bien me solucionó él la papeleta) con la web de Launchpad y los archivos .deb


Descargue la de 32bit que necesitaba para Guadalinex v8 y al instalarla por dpkg me tiraba errores por dependencias incumplidas, más concretamente con libc6, una de las librerías (bibliotecas) más importantes en sistemas Linux. Al instalar libc6 me volvió a arrojar otro problema, libc6 depende de libc-bin para poder ser ejecutada. Total que al final instalando libc-bin y libc6 (en ese orden) ya se pudo instalar el .deb de Launchpad bash 4.2-2ubuntu2.2 y dar por solucionada la vulnerabilidad en el servidor con Guadalinex v8.

Aunque esperamos poder instalar una nueva distribución más actual para este servidor está solución es totalmente eficiente, eso si, solo ha sido en Guadalinex con la versión v8 basada en Presice.

No sé si esto último lo había dicho ya ;)